Datum |
Identifies whether the curve representing the datum plane is displayed according to its actual 3d extents, or else according to a view specific setting.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- datumEnd DatumEnds
- Specifies one end of the curve representing the datum plane in the view.
- view View
- The view in which to evaluate the datum extent settings.
Return Value
DatumExtentTypeThe extent type.

Exception | Condition |
---|---|
ArgumentException | The datum plane cannot be visible in the view. |
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |

In a particular view, the datum plane is represented by a curve and the two ends of the curve may have different DatumExtentTypes in that view.