CurveElementFilter Constructor (CurveElementType, Boolean)


Constructs a new instance of a filter to match specific types of curve elements, with the option to match all curves which are not of the given curve type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public CurveElementFilter(
	CurveElementType curveElementType,
	bool inverted
)
Visual Basic
Public Sub New ( _
	curveElementType As CurveElementType, _
	inverted As Boolean _
)
Visual C++
public:
CurveElementFilter(
	CurveElementType curveElementType, 
	bool inverted
)

Parameters

curveElementType
Type: Autodesk.Revit.DBCurveElementType
The curve element type to match.
inverted
Type: SystemBoolean
True if the filter should match all curves which are not of the given curve type.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also