CurveElementFilter Constructor (CurveElementType, Boolean)


Curve Element Filter(Curve Element Type, Boolean) Constructor

Constructs a new instance of a filter to match specific types of curve elements, with the option to match all curves which are not of the given curve type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public CurveElementFilter(
	CurveElementType curveElementType,
	bool inverted
)

Parameters

curveElementType CurveElementType
The curve element type to match.
inverted Boolean
True if the filter should match all curves which are not of the given curve type.
Exceptions
Exception Condition
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also