SetParameterValue Method


Sets a new parameter value of this subelement given a parameter id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2018

Syntax

C#
public void SetParameterValue(
	ElementId parameterId,
	ParameterValue pValue
)
Visual Basic
Public Sub SetParameterValue ( _
	parameterId As ElementId, _
	pValue As ParameterValue _
)
Visual C++
public:
void SetParameterValue(
	ElementId^ parameterId, 
	ParameterValue^ pValue
)

Parameters

parameterId
Type: Autodesk.Revit.DBElementId
Parameter id.
pValue
Type: Autodesk.Revit.DBParameterValue
New value for the parameter.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException parameterId does not identify a valid parameter of this subelement. -or- The parameter parameterId is not modifiable for this subelement.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also