Obtains the spatial element boundary curves as an array of CurveLoops, needed for processing into IFC-specific elements later.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- spatialElement
- Type: Autodesk.Revit.DBSpatialElement
The spatial element.
- options
- Type: Autodesk.Revit.DBSpatialElementBoundaryOptions
The options for extraction of the boundaries.
- cleanCurves
- Type: SystemBoolean
If true, curves will be trimmed to meet their neighbors. If false, no trimming will take place.
Return Value
The list of CurveLoops, which could be empty if the routine is unable to get the boundary curve loops.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | Throws an exception if any of the boundary loops are invalid or degenerate. |