GetRoomBoundaryAsCurveLoopArray Method


Exporter IFCUtils Get Room Boundary As Curve Loop Array Method

Obtains the spatial element boundary curves as an array of CurveLoops, needed for processing into IFC-specific elements later.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static IList<CurveLoop> GetRoomBoundaryAsCurveLoopArray(
	SpatialElement spatialElement,
	SpatialElementBoundaryOptions options,
	bool cleanCurves
)

Parameters

spatialElement SpatialElement
The spatial element.
options SpatialElementBoundaryOptions
The options for extraction of the boundaries.
cleanCurves Boolean
If true, curves will be trimmed to meet their neighbors. If false, no trimming will take place.

Return Value

IList CurveLoop
The list of CurveLoops, which could be empty if the routine is unable to get the boundary curve loops.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
InvalidOperationException Throws an exception if any of the boundary loops are invalid or degenerate.
See Also