AreElementsValidForMultiReferenceAnnotation Method


The method validates if the input elements match the element category id for the MultiReferenceAnnotationType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2020

Syntax

C#
public static bool AreElementsValidForMultiReferenceAnnotation(
	Document document,
	MultiReferenceAnnotationOptions options
)
Visual Basic
Public Shared Function AreElementsValidForMultiReferenceAnnotation ( _
	document As Document, _
	options As MultiReferenceAnnotationOptions _
) As Boolean
Visual C++
public:
static bool AreElementsValidForMultiReferenceAnnotation(
	Document^ document, 
	MultiReferenceAnnotationOptions^ options
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document for the multi-reference annotation.
options
Type: Autodesk.Revit.DBMultiReferenceAnnotationOptions
The creation options for the new MultiReferenceAnnotation.

Return Value

Returns true if the input elements match the element category id for the MultiReferenceAnnotationType, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also