AreElementsValidForMultiReferenceAnnotation Method


Multi Reference Annotation Are Elements Valid For Multi Reference Annotation Method

The method validates if the input elements match the element category id for the MultiReferenceAnnotationType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool AreElementsValidForMultiReferenceAnnotation(
	Document document,
	MultiReferenceAnnotationOptions options
)

Parameters

document Document
The document for the multi-reference annotation.
options MultiReferenceAnnotationOptions
The creation options for the new MultiReferenceAnnotation.

Return Value

Boolean
Returns true if the input elements match the element category id for the MultiReferenceAnnotationType, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also