SetLinePattern Method


Sets the LinePattern associated to this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public void SetLinePattern(
	LinePattern newLinePattern
)
Visual Basic
Public Sub SetLinePattern ( _
	newLinePattern As LinePattern _
)
Visual C++
public:
void SetLinePattern(
	LinePattern^ newLinePattern
)

Parameters

newLinePattern
Type: Autodesk.Revit.DBLinePattern
The new LinePattern object.

Remarks

The data stored inside the input LinePattern will be copied into this element. The input LinePattern itself will not be associated with the element.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The Line Pattern is not valid.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also