Line |
Sets the LinePattern associated to this element.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- newLinePattern LinePattern
- The new LinePattern object.

Exception | Condition |
---|---|
ArgumentException | The Line Pattern is not valid. |
ArgumentNullException | A non-optional argument was null |

The data stored inside the input LinePattern will be copied into this element. The input LinePattern itself will not be associated with the element.