Gets the Element referenced by a unique id string.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- uniqueId
- Type: SystemString
The element unique id, whose referenced Element will be retrieved from the model.- UniqueId
Return Value
The element referenced by the input argument.Remarks
a null reference (Nothing in Visual Basic) will be returned if the input id string doesn't reference to a valid Element.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |