GetElement Method (String)


Document Get Element(String) Method

Gets the Element referenced by a unique id string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Element GetElement(
	string uniqueId
)

Parameters

uniqueId String
The element unique id, whose referenced Element will be retrieved from the model.
  • UniqueId
  • Return Value

    Element
    The element referenced by the input argument.
    Exceptions
    Exception Condition
    ArgumentNullException A non-optional argument was null
    Remarks
    will be returned if the input id string doesn't reference to a valid Element.
    See Also