Add Method


Inserts a (key,info) pair into Export font table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public void Add(
	ExportFontKey exportFontKey,
	ExportFontInfo exportFontInfo
)
Visual Basic
Public Sub Add ( _
	exportFontKey As ExportFontKey, _
	exportFontInfo As ExportFontInfo _
)
Visual C++
public:
void Add(
	ExportFontKey^ exportFontKey, 
	ExportFontInfo^ exportFontInfo
)

Parameters

exportFontKey
Type: Autodesk.Revit.DBExportFontKey
The export font key to be added.
exportFontInfo
Type: Autodesk.Revit.DBExportFontInfo
The export font info to be added.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The key already exists in the table.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also