Returns the normal of plane in which the hook at end of bar with index barPositionIndex will stay.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- end
- Type: SystemInt32
The end of bar. Should be 0 for start or 1 for end.
- barPositionIndex
- Type: SystemInt32
An index between 0 and (NumberOfBarPositions-1).
Return Value
The normal of plane in which the hook at end of bar with index barPositionIndex will stay.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | barPositionIndex is not in the range [ 0, NumberOfBarPositions-1 ]. -or- Invalid end. |