Rebar
|
Note: This API is now obsolete.
Returns the plane's normal in which the termination (e.g. hook, crank) at end of bar with index barPositionIndex will stay.
The plane's normal is used for both hook and crank.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

[ObsoleteAttribute("This method is deprecated in Revit 2026 and may be removed in a later version of Revit. Please use RebarFreeFormAccessor.GetTerminationPlaneNormalForBarIndex instead.")]
public XYZ GetHookPlaneNormalForBarIdx(
int end,
int barPositionIndex
)
Parameters
- end Int32
- The end of bar. Should be 0 for start or 1 for end.
- barPositionIndex Int32
- An index between 0 and (NumberOfBarPositions-1).
Return Value
XYZThe plane's normal in which the termination (e.g. hook, crank) at end of bar with index barPositionIndex will stay. The plane's normal is used for both hook and crank.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | barPositionIndex is not in the range [ 0, NumberOfBarPositions-1 ]. -or- Invalid end. |