GetLevelIdByHeight Method


Gets the level if by the height of the element.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public static ElementId GetLevelIdByHeight(
	ExporterIFC exporterIFC,
	Element elem
)
Visual Basic
Public Shared Function GetLevelIdByHeight ( _
	exporterIFC As ExporterIFC, _
	elem As Element _
) As ElementId
Visual C++
public:
static ElementId^ GetLevelIdByHeight(
	ExporterIFC^ exporterIFC, 
	Element^ elem
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFCExporterIFC
The exporter.
elem
Type: Autodesk.Revit.DBElement
The element.

Return Value

The level id.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also