Gets the default element type id with the given DefaultElementType id.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- defaultTypeId
- Type: Autodesk.Revit.DBElementTypeGroup
The default element type id.
Return Value
The element type id.Examples

private bool IsWallUsingDefaultType(Document document, Wall wall)
{
ElementId defaultElementTypeId = document.GetDefaultElementTypeId(ElementTypeGroup.WallType);
return (wall.WallType.Id == defaultElementTypeId);
}

Private Function IsWallUsingDefaultType(document As Document, wall As Wall) As Boolean
Dim defaultElementTypeId As ElementId = document.GetDefaultElementTypeId(ElementTypeGroup.WallType)
Return (wall.WallType.Id = defaultElementTypeId)
End Function
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |