GetDefaultElementTypeId Method


Document Get Default Element Type Id Method

Gets the default element type id with the given DefaultElementType id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementId GetDefaultElementTypeId(
	ElementTypeGroup defaultTypeId
)

Parameters

defaultTypeId ElementTypeGroup
The default element type id.

Return Value

ElementId
The element type id.
Exceptions
Exception Condition
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
Example
private bool IsWallUsingDefaultType(Document document, Wall wall)
{
    ElementId defaultElementTypeId = document.GetDefaultElementTypeId(ElementTypeGroup.WallType);
    return (wall.WallType.Id == defaultElementTypeId);
}
See Also