The currently active view of the currently active document.
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
Remarks
This property is applicable to the currently active document only. Returns a null reference (Nothing in Visual Basic) if this document doesn't represent the active document.
The active view can only be changed when:
- There is no open transaction.
- IsModifiable is false.
- IsReadOnly is false.
- ViewActivating, ViewActivated, and any pre-action of events (such as DocumentSaving or DocumentClosingevents) are not being handled.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | When setting the property: If the 'view' argument is NULL. |
Autodesk.Revit.ExceptionsArgumentException | When setting the property:
|
Autodesk.Revit.ExceptionsInvalidOperationException | When setting the property:
|