ActiveView Property


UIDocument Active View Property

The currently active view of the currently active document.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public View ActiveView { get; set; }

Property Value

View
Exceptions
Exception Condition
ArgumentNullException When setting the property: If the 'view' argument is NULL.
ArgumentException When setting the property:
  • If the given view is not a valid view of the document; -or-
  • If the given view is a template view; -or-
  • If the given view is an internal view.
InvalidOperationException

When setting the property:

  • If the document is not currently active; -or-
  • If the document is currently modifiable (i.e. with an active transaction); -or-
  • If the document is currently in read-only state; -or-
  • When invoked during either ViewActivating or ViewActivated event; -or-
  • When invoked during any pre-action kind of event, such as DocumentSaving, DocumentClosing, etc.

Remarks

This property is applicable to the currently active document only. Returns if this document doesn't represent the active document.

The active view can only be changed when:

  • There is no open transaction.
  • IsModifiable is false.
  • IsReadOnly is false.
  • ViewActivating, ViewActivated, and any pre-action of events (such as DocumentSaving or DocumentClosingevents) are not being handled.

See Also