Create Method


Creates a new CoverType in the document.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static RebarCoverType Create(
	Document doc,
	string name,
	double coverDistance
)
Visual Basic
Public Shared Function Create ( _
	doc As Document, _
	name As String, _
	coverDistance As Double _
) As RebarCoverType
Visual C++
public:
static RebarCoverType^ Create(
	Document^ doc, 
	String^ name, 
	double coverDistance
)

Parameters

doc
Type: Autodesk.Revit.DBDocument
name
Type: SystemString
coverDistance
Type: SystemDouble

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException name is an empty string.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException coverDistance cannot be negative.

See Also