FindPoints Method


Filters and returns only the points of the topography surface which lie within the input bounding box.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public IList<XYZ> FindPoints(
	Outline boundingBox
)
Visual Basic
Public Function FindPoints ( _
	boundingBox As Outline _
) As IList(Of XYZ)
Visual C++
public:
IList<XYZ^>^ FindPoints(
	Outline^ boundingBox
)

Parameters

boundingBox
Type: Autodesk.Revit.DBOutline
The 3D bounding box.

Return Value

The result points within the 3D bounding box

Remarks

This applies to TopographySurface, SiteSubRegion, and the topography surface associated with a BuildingPad element.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException boundingBox is an empty Outline.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also