Topography |
Filters and returns only the points of the topography surface which lie within the input bounding box.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- boundingBox Outline
- The 3D bounding box.
Return Value
IList XYZThe result points within the 3D bounding box

Exception | Condition |
---|---|
ArgumentException | boundingBox is an empty Outline. |
ArgumentNullException | A non-optional argument was null |

This applies to TopographySurface, SiteSubRegion, and the topography surface associated with a BuildingPad element.