Gets Adaptive Point Element Ref ids to which the instance geometry adapts.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- famInst
- Type: Autodesk.Revit.DBFamilyInstance
The FamilyInstance.
Return Value
The Adaptive Point Element Ref ids to which the instance geometry adapts.Remarks
The output contains both placement point ref ids and the shape handles point ref ids. The order corresponds to the same order as that of the Adaptive Points in the Family (which may not be ordered as per their placement number). Will return an empty array if there are no placement points and shape handles. To manipulate such an instance the following methods can be useful: 1) RehostAdaptiveComponentInstanceWithNoPlacementPoints() 2) MoveAdaptiveComponentInstance()
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The FamilyInstance famInst is not an Adaptive Family Instance. -or- The FamilyInstance famInst does not have an Adaptive Family Symbol. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | This operation failed. |