GetInstancePointElementRefIds Method


Adaptive Component Instance Utils Get Instance Point Element Ref Ids Method

Gets Adaptive Point Element Ref ids to which the instance geometry adapts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static IList<ElementId> GetInstancePointElementRefIds(
	FamilyInstance famInst
)

Parameters

famInst FamilyInstance
The FamilyInstance.

Return Value

IList ElementId
The Adaptive Point Element Ref ids to which the instance geometry adapts.
Exceptions
Exception Condition
ArgumentException The FamilyInstance famInst is not an Adaptive Family Instance. -or- The FamilyInstance famInst does not have an Adaptive Family Symbol.
ArgumentNullException A non-optional argument was null
InvalidOperationException This operation failed.
Remarks
The output contains both placement point ref ids and the shape handles point ref ids. The order corresponds to the same order as that of the Adaptive Points in the Family (which may not be ordered as per their placement number). Will return an empty array if there are no placement points and shape handles. To manipulate such an instance the following methods can be useful: 1) RehostAdaptiveComponentInstanceWithNoPlacementPoints() 2) MoveAdaptiveComponentInstance()
See Also