Create an opening to cut the wall or ceiling.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- host
- Type: Autodesk.Revit.DBElement
Host elements that new opening would lie in. The host can only be a wall or a ceiling.
- profile
- Type: Autodesk.Revit.DBCurveArray
The profile of the newly created opening. This may contain more than one curve loop. Each loop must be a fully closed curve loop and the loops may not intersect. The profiles will be projected into the host plane.
Return Value
If successful, the newly created opening is returned, otherwise an exception with error information will be thrown.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | Thrown when the input argument host or profile is a null reference (Nothing in Visual Basic). |
Autodesk.Revit.ExceptionsArgumentException | Thrown when host isn't a wall or a ceiling. Thrown when profile doesn't contain any loops. |
Autodesk.Revit.ExceptionsInvalidOperationException | Thrown when opening creation failed. |