NewOpening Method


Family Item Factory New Opening Method

Create an opening to cut the wall or ceiling.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Opening NewOpening(
	Element host,
	CurveArray profile
)

Parameters

host Element
Host elements that new opening would lie in. The host can only be a wall or a ceiling.
profile CurveArray
The profile of the newly created opening. This may contain more than one curve loop. Each loop must be a fully closed curve loop and the loops may not intersect. The profiles will be projected into the host plane.

Return Value

Opening
If successful, the newly created opening is returned, otherwise an exception with error information will be thrown.
Exceptions
Exception Condition
ArgumentNullException Thrown when the input argument host or profile is .
ArgumentException Thrown when host isn't a wall or a ceiling. Thrown when profile doesn't contain any loops.
InvalidOperationException Thrown when opening creation failed.
See Also