Removes the modifications made during editing and resets the element geometry back to the unmodified state.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
Calling this method will reset the slab back to its original state and disable Slab Shape Editing. If further editing is needed, call Enable again.
Examples

private void ResetSlabShapes(Autodesk.Revit.DB.Document document)
{
UIDocument uidoc = new UIDocument(document);
ICollection<ElementId> selectedIds = uidoc.Selection.GetElementIds();
foreach (ElementId id in selectedIds)
{
Floor floor = document.GetElement(id) as Floor;
if (floor != null)
{
SlabShapeEditor slabShapeEditor = floor.GetSlabShapeEditor();
slabShapeEditor.ResetSlabShape();
}
}
}

Private Sub ResetSlabShapes(document As Autodesk.Revit.DB.Document)
Dim uidoc As New UIDocument(document)
Dim selectedIds As ICollection(Of ElementId) = uidoc.Selection.GetElementIds()
For Each id As ElementId In selectedIds
Dim floor As Floor = TryCast(document.GetElement(id), Floor)
If floor IsNot Nothing Then
Dim slabShapeEditor As SlabShapeEditor = floor.GetSlabShapeEditor()
slabShapeEditor.ResetSlabShape()
End If
Next
End Sub