Slab |
Removes the modifications made during editing and resets the element geometry back to the unmodified state.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)


Calling this method will reset the slab back to its original state and disable Slab Shape Editing. If further editing is needed, call Enable again.

private void ResetSlabShapes(Autodesk.Revit.DB.Document document)
{
UIDocument uidoc = new UIDocument(document);
ICollection<ElementId> selectedIds = uidoc.Selection.GetElementIds();
foreach (ElementId id in selectedIds)
{
Floor floor = document.GetElement(id) as Floor;
if (floor != null)
{
SlabShapeEditor slabShapeEditor = floor.GetSlabShapeEditor();
slabShapeEditor.ResetSlabShape();
}
}
}