SetDetailLevel Method


Sets the detail level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public OverrideGraphicSettings SetDetailLevel(
	ViewDetailLevel detailLevel
)
Visual Basic
Public Function SetDetailLevel ( _
	detailLevel As ViewDetailLevel _
) As OverrideGraphicSettings
Visual C++
public:
OverrideGraphicSettings^ SetDetailLevel(
	ViewDetailLevel detailLevel
)

Parameters

detailLevel
Type: Autodesk.Revit.DBViewDetailLevel
Value of the detail level. ViewDetailLevel.Undefined means no override is set.

Return Value

Reference to the changed object.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also