SetDetailLevel Method


Override Graphic Settings Set Detail Level Method

Sets the detail level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public OverrideGraphicSettings SetDetailLevel(
	ViewDetailLevel detailLevel
)

Parameters

detailLevel ViewDetailLevel
Value of the detail level. ViewDetailLevel.Undefined means no override is set.

Return Value

OverrideGraphicSettings
Reference to the changed object.
Exceptions
Exception Condition
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also