BreakCurve Method


Breaks the duct curve into two parts at the given position.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2017

Syntax

C#
public static ElementId BreakCurve(
	Document document,
	ElementId ductId,
	XYZ ptBreak
)
Visual Basic
Public Shared Function BreakCurve ( _
	document As Document, _
	ductId As ElementId, _
	ptBreak As XYZ _
) As ElementId
Visual C++
public:
static ElementId^ BreakCurve(
	Document^ document, 
	ElementId^ ductId, 
	XYZ^ ptBreak
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document.
ductId
Type: Autodesk.Revit.DBElementId
The element id of the duct curve to break.
ptBreak
Type: Autodesk.Revit.DBXYZ
The break point on the duct curve.

Return Value

The new duct curve element id if successful otherwise if a failure occurred an invalidElementId is returned.

Remarks

This method is not applicable for breaking the flex duct.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException "The element is neither a duct nor a duct placeholder." -or- "The given point is not on the duct curve."
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also