Mechanical |
Breaks the duct curve into two parts at the given position.
Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- document Document
- The document.
- ductId ElementId
- The element id of the duct curve to break.
- ptBreak XYZ
- The break point on the duct curve.
Return Value
ElementIdThe new duct curve element id if successful otherwise if a failure occurred an invalidElementId is returned.

Exception | Condition |
---|---|
ArgumentException | "The element is neither a duct nor a duct placeholder." -or- "The given point is not on the duct curve." |
ArgumentNullException | A non-optional argument was null |

This method is not applicable for breaking the flex duct.