Cancel Method


Requests to cancel the progress bar's operation.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public void Cancel()
Visual Basic
Public Sub Cancel
Visual C++
public:
void Cancel()

Remarks

Note that an operation may only be cancelled if its stage is 'Unchanged' or if its stage is 'PositionChanged' and the 'Cancellable' property is 'true.'

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsInvalidOperationException The operation cannot be cancelled.

See Also