MirrorElements Method (Document, ICollection(ElementId), Plane, Boolean)


Mirrors a set of elements about a given plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2016

Syntax

C#
public static IList<ElementId> MirrorElements(
	Document document,
	ICollection<ElementId> elementsToMirror,
	Plane plane,
	bool mirrorCopies
)
Visual Basic
Public Shared Function MirrorElements ( _
	document As Document, _
	elementsToMirror As ICollection(Of ElementId), _
	plane As Plane, _
	mirrorCopies As Boolean _
) As IList(Of ElementId)
Visual C++
public:
static IList<ElementId^>^ MirrorElements(
	Document^ document, 
	ICollection<ElementId^>^ elementsToMirror, 
	Plane^ plane, 
	bool mirrorCopies
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document that owns the elements.
elementsToMirror
Type: System.Collections.GenericICollectionElementId
The set of elements to mirror.
plane
Type: Autodesk.Revit.DBPlane
The mirror plane.
mirrorCopies
Type: SystemBoolean
True if mirroring should be performed on copies of the elements, leaving the original elements intact. False if no copies should be created and the elements should be mirrored directly.

Return Value

A collection of ids of newly created elements - mirrored copies. It is empty if the mirrorCopies arguments is false.

Remarks

Optionally, copies of the elements can be created prior to the operation and mirroring is then performed on the copies instead of the original elements.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException elementsToMirror cannot be mirrored. -or- The given element id set is empty. -or- One or more elements in elementsToMirror do not exist in the document. -or- Some of the elements cannot be copied, because they belong to different views. -or- The input set of elements contains Sketch members along with other elements or there is no active Sketch edit mode.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException Thrown when the elements cannot be moved (e.g. due to some of the elements being pinned).

See Also