GetServiceGUID Method


Gets the service GUID by its identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public Guid GetServiceGUID(
	int serviceId
)
Visual Basic
Public Function GetServiceGUID ( _
	serviceId As Integer _
) As Guid
Visual C++
public:
Guid GetServiceGUID(
	int serviceId
)

Parameters

serviceId
Type: System Int32
The service identifier.

Return Value

The service GUID. Returns empty GUID if not found.

See Also