ConicalSurface Class


A Conical Surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2017

Syntax

C#
public class ConicalSurface : Surface
Visual Basic
Public Class ConicalSurface _
	Inherits Surface
Visual C++
public ref class ConicalSurface : public Surface

Remarks

The parametric equation of the cone is S(u, v) = center + v*[sin(halfAngle)(cos(u)*xVec + sin(u)*yVec) + cos(halfAngle)*zVec]. Only the branch of the cone with v >= 0 should be used.

Inheritance Hierarchy

SystemObject
  Autodesk.Revit.DBSurface
    Autodesk.Revit.DBConicalSurface

See Also