Conical |
A Conical Surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The ConicalSurface type exposes the following members.

Name | Description | |
---|---|---|
![]() | Axis | Axis of the cone. This is the Z axis of the local coordinate system associated with this cone. |
![]() | HalfAngle | Cone angle. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Surface ) |
![]() | OrientationMatchesParametricOrientation | Indicates whether this Surface's orientation is the same as or opposite to its parametric orientation. (Inherited from Surface ) |
![]() | Origin | Apex of the cone. This is the origin of the local coordinate system associated with this cone. |
![]() | XDir | X axis of the local coordinate system associated with this cone. |
![]() | YDir | X axis of the local coordinate system associated with this cone. |

Name | Description | |
---|---|---|
![]() ![]() | Create | Creates a conical surface defined by a local reference frame and a half angle. |
![]() | Dispose | (Inherited from Surface ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetBoundingBoxUV | Gets the UV bounding box of the surface. (Inherited from Surface ) |
![]() | GetFrameOfReference | Returns frame of reference associated with this ConicalSurface. |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() ![]() | IsValidConeAngle | Checks whether the input value lies is not 0, greater than -PI/2 and lesser than PI/2. |
![]() | Project | Project a 3D point orthogonally onto a surface (to find the nearest point). Throws InvalidOperationException if the projection fails. (Inherited from Surface ) |
![]() | ProjectWithGuessPoint | Project a 3D point orthogonally onto a surface (to find the nearest point). This method is meant to be used when a good approximate solution for the projection is available. Throws InvalidOperationException if the projection fails. (Inherited from Surface ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

The parametric equation of the cone is S(u, v) = center + v*[sin(halfAngle)(cos(u)*xVec + sin(u)*yVec) + cos(halfAngle)*zVec]. Only the branch of the cone with v >= 0 should be used.