Conical |
A Conical Surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The ConicalSurface type exposes the following members.

Name | Description | |
---|---|---|
![]() | Axis | Axis of the cone. This is the Z axis of the local coordinate system associated with this cone. |
![]() | HalfAngle | Cone angle. |
![]() | Origin | Apex of the cone. This is the origin of the local coordinate system associated with this cone. |
![]() | XDir | X axis of the local coordinate system associated with this cone. |
![]() | YDir | X axis of the local coordinate system associated with this cone. |

Name | Description | |
---|---|---|
![]() ![]() | Create | Creates a conical surface defined by a local reference frame and a half angle. |
![]() | GetFrameOfReference | Returns frame of reference associated with this ConicalSurface. |
![]() ![]() | IsValidConeAngle | Checks whether the input value lies is not 0, greater than -PI/2 and lesser than PI/2. |

The parametric equation of the cone is S(u, v) = center + v*[sin(halfAngle)(cos(u)*xVec + sin(u)*yVec) + cos(halfAngle)*zVec]. Only the branch of the cone with v >= 0 should be used.