SetDefaultElementTypeId Method


Sets the default element type id of the given DefaultElementType id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2015

Syntax

C#
public void SetDefaultElementTypeId(
	ElementTypeGroup defaultTypeId,
	ElementId typeId
)
Visual Basic
Public Sub SetDefaultElementTypeId ( _
	defaultTypeId As ElementTypeGroup, _
	typeId As ElementId _
)
Visual C++
public:
void SetDefaultElementTypeId(
	ElementTypeGroup defaultTypeId, 
	ElementId^ typeId
)

Parameters

defaultTypeId
Type: Autodesk.Revit.DBElementTypeGroup
The default element type id.
typeId
Type: Autodesk.Revit.DBElementId
The element type id.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The element type id typeId is invalid for the give DefaultElementType id defaultTypeId.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also