SetDefaultElementTypeId Method


Document Set Default Element Type Id Method

Sets the default element type id of the given DefaultElementType id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetDefaultElementTypeId(
	ElementTypeGroup defaultTypeId,
	ElementId typeId
)

Parameters

defaultTypeId ElementTypeGroup
The default element type id.
typeId ElementId
The element type id.
Exceptions
Exception Condition
ArgumentException The element type id typeId is invalid for the give DefaultElementType id defaultTypeId.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also