CanElementsBeDisplaced Method (View, ICollection(ElementId), ElementId)


Indicates if elements can be assigned to a new DisplacementElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public static bool CanElementsBeDisplaced(
	View view,
	ICollection<ElementId> elementIds,
	out ElementId commonDisplacedElementId
)
Visual Basic
Public Shared Function CanElementsBeDisplaced ( _
	view As View, _
	elementIds As ICollection(Of ElementId), _
	<OutAttribute> ByRef commonDisplacedElementId As ElementId _
) As Boolean
Visual C++
public:
static bool CanElementsBeDisplaced(
	View^ view, 
	ICollection<ElementId^>^ elementIds, 
	[OutAttribute] ElementId^% commonDisplacedElementId
)

Parameters

view
Type: Autodesk.Revit.DBView
The view.
elementIds
Type: System.Collections.GenericICollectionElementId
The element ids.
commonDisplacedElementId
Type: Autodesk.Revit.DBElementId%
If this method returns true, then this is the element id of a DisplacementElement which lists all of elemIds among its displaced elements.

Return Value

Returns true if the specified element ids can be assigned to a new DisplacementElement.

Remarks

A necessary condition is that isAllowedAsDisplacedElement returns true for each individual element id. In addition, if isElementDisplaced must return the same value for all the specified element ids.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also