CanElementsBeDisplaced Method (View, ICollection(ElementId), ElementId)


Displacement Element Can Elements Be Displaced(View, ICollection Element Id , Element Id ) Method

Indicates if elements can be assigned to a new DisplacementElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool CanElementsBeDisplaced(
	View view,
	ICollection<ElementId> elementIds,
	out ElementId commonDisplacedElementId
)

Parameters

view View
The view.
elementIds ICollection ElementId
The element ids.
commonDisplacedElementId ElementId
If this method returns true, then this is the element id of a DisplacementElement which lists all of elemIds among its displaced elements.

Return Value

Boolean
Returns true if the specified element ids can be assigned to a new DisplacementElement.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
A necessary condition is that isAllowedAsDisplacedElement returns true for each individual element id. In addition, if isElementDisplaced must return the same value for all the specified element ids.
See Also