Create Method (Document, ElementId, String)


Creates a new instance of a piping system and adds it to the document.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public static PipingSystem Create(
	Document ADocument,
	ElementId typeId,
	string name
)
Visual Basic
Public Shared Function Create ( _
	ADocument As Document, _
	typeId As ElementId, _
	name As String _
) As PipingSystem
Visual C++
public:
static PipingSystem^ Create(
	Document^ ADocument, 
	ElementId^ typeId, 
	String^ name
)

Parameters

ADocument
Type: Autodesk.Revit.DBDocument
The document where the element will be created and added.
typeId
Type: Autodesk.Revit.DBElementId
The identifier of this piping system element's type.
name
Type: SystemString
The name of the piping system to be created.

Return Value

The newly created piping system element.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The typeId is not an element id for a valid piping system type.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsDisabledDisciplineException None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also