Create Method (Document, ElementId, String)


Piping System Create(Document, Element Id, String) Method

Creates a new instance of a piping system and adds it to the document.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static PipingSystem Create(
	Document ADocument,
	ElementId typeId,
	string name
)

Parameters

ADocument Document
The document where the element will be created and added.
typeId ElementId
The identifier of this piping system element's type.
name String
The name of the piping system to be created.

Return Value

PipingSystem
The newly created piping system element.
Exceptions
Exception Condition
ArgumentException The typeId is not an element id for a valid piping system type.
ArgumentNullException A non-optional argument was null
See Also