Add Method


Inserts a (key, info) pair into Export line weight table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Add(
	ExportLineweightKey exportLineweightKey,
	ExportLineweightInfo exportLineweightInfo
)
Visual Basic
Public Sub Add ( _
	exportLineweightKey As ExportLineweightKey, _
	exportLineweightInfo As ExportLineweightInfo _
)
Visual C++
public:
void Add(
	ExportLineweightKey^ exportLineweightKey, 
	ExportLineweightInfo^ exportLineweightInfo
)

Parameters

exportLineweightKey
Type: Autodesk.Revit.DBExportLineweightKey
The export line weight Key to be added.
exportLineweightInfo
Type: Autodesk.Revit.DBExportLineweightInfo
The export line weight info to be added.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The key already exists in the table.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also