Add Method


Export Lineweight Table Add Method

Inserts a (key, info) pair into Export line weight table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void Add(
	ExportLineweightKey exportLineweightKey,
	ExportLineweightInfo exportLineweightInfo
)

Parameters

exportLineweightKey ExportLineweightKey
The export line weight Key to be added.
exportLineweightInfo ExportLineweightInfo
The export line weight info to be added.
Exceptions
Exception Condition
ArgumentException The key already exists in the table.
ArgumentNullException A non-optional argument was null
See Also