DisconnectFrom Method


Remove connection between two connectors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void DisconnectFrom(
	Connector connector
)
Visual Basic
Public Sub DisconnectFrom ( _
	connector As Connector _
)
Visual C++
public:
void DisconnectFrom(
	Connector^ connector
)

Parameters

connector
Type: Autodesk.Revit.DBConnector
Indicate the connector, connection will be removed from.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException Thrown when argument is a null reference (Nothing in Visual Basic).
Autodesk.Revit.ExceptionsArgumentException Argument is invalid.
Autodesk.Revit.ExceptionsInvalidOperationException Thrown when no connection between these two connector. Thrown on failure to remove the connection between these two connectors.

See Also