This function checks if a parameter uses level filtering.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- doc
- Type: Autodesk.Revit.DBDocument
The document which owns the parameter.
- parameterId
- Type: Autodesk.Revit.DBElementId
The id of the parameter that will be tested to see if it uses level filtering.
Return Value
True if the parameter uses level filtering, false otherwise.Remarks
When level-filtering parameters are compared, the comparisons will first compare the values of the levels' elevations, then compare the levels' names, and finally the levels' element ids to rank and sort the levels.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |