UsesLevelFiltering Method


Filter Element Id Rule Uses Level Filtering Method

This function checks if a parameter uses level filtering.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool UsesLevelFiltering(
	Document doc,
	ElementId parameterId
)

Parameters

doc Document
The document which owns the parameter.
parameterId ElementId
The id of the parameter that will be tested to see if it uses level filtering.

Return Value

Boolean
True if the parameter uses level filtering, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
When level-filtering parameters are compared, the comparisons will first compare the values of the levels' elevations, then compare the levels' names, and finally the levels' element ids to rank and sort the levels.
See Also