Determines whether this 2-D vector and the specified 2-D vector are the same within a specified tolerance.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- source
- Type: Autodesk.Revit.DBUV
The vector to compare with this vector.
- tolerance
- Type: SystemDouble
The tolerance for equality check.
Return Value
True if the vectors are the same; otherwise, false.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | Thrown when source is a null reference (Nothing in Visual Basic). |
Autodesk.Revit.ExceptionsArgumentException | Thrown when tolerance is less than 0. |